2010-02-03 - symfony might not play HipHop ...

This is a small note about the new buzz word in the PHP world : 'HipHop'. After reading the original facebook post about 'HipHop' and the 'devil' eval() function, I start thinking about possible issues with the symfony framework.

If the eval function is not compatible with HipHop, I guess other features are not HipHop friendly

Now, these features are evil but there are used in some part of symfony's dependencies : symfony core lib, sfForm, Doctrine and Propel.

I will be please to see how symfony and co will deal with this new PHP compiler. If the performance are really good and free as a beer, HipHop can create new and interesting challenge for popular frameworks.

But for now, symfony will not play HipHop when the tool will be release :(

Comments

comments powered by Disqus